Block Facebook diLayer7 & schedule

Artikel berikut berisi informasi bagaimana memblok akses Facebook dengan layer7 Winbox. Mengapa layer7? Admin jaringan kami sebelumnya pernah menerapkan blok akses Facebook dengan cara drop by content pada Firewall. Hasilnya Facebook.com memang berhasil diblok, namun beberapa website (seperti forum cpanel dan website lain yang mengandung konten Facebook) ikut terblok. Setelah dicoba menerapkan rule blok akses Facebook dengan layer7, hasilnya sesuai dengan harapan. Akses ke Facebook berhasil terblok, namun tidak ikut berimbas website lain.

Pertama buat Buat rgxp di layer 7, yaitu sebagai berikut :

facebook.com (facebook)
contoh yang lain
twitter.com (twitter)
youtube.com (youtube)
^.+(youtube|tube|mivo).*$ (streaming)
^.*get.+\.(asf|mov|wmv|mpg|mpeg|mkv|avi|flv|wav|rm|mp3|mp4|ram |rmvb|dat|daa|iso|nrg|bin|vcd|mp2|3gp|mpe|qt|raw|wma|0[0-9][0-9]).*$ (content)
^.+(game|poker|viwawa).*$ (game)
^.+(platform.twitter.com).*$ (platform.twitter.com/widgets.js)
^.+(porn|xxx|sex).*$ (porn)
^.+(facebook|twitter).*$ (social)
add regexp=facebook.com name=facebook
Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut:
add chain=forward  layer7-protocol=Facebook dst-address-list=staff action=drop comment=”Blockir Akses Facebook”
Cara dibawah digunakan jika langsung block dari filter rule tapi kelemahannya jika ada content facebok akan langsung di blok. Perbedaannya jika menggunakan layer 7 karena layer 7 berada pada layer yang paling atas jadi semua alamat dari facebook akan terblock.
/add chain=forward action=drop protocol=tcp src-address=0.0.0.0/0 dst-port=80 content=”facebook” comment=”Blockir Akses Facebook”
Ketiga, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL: ntp.kim.lipi.go.id (203.160.128.6) dan NTP Pool Project dengan salah satu URLnya: 0.id.pool.ntp.org (202.169.224.16). Untuk mensettingnya di MikroTik, ketikkan perintah berikut :
/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes;
Keempat, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan  (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :
Script untuk mematikan (disable) firewall
/system script add name=”fb-allow” policy=read,write,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=yes}
Script untuk mengaktifkan (enable) firewall :
/system script add name=”fb-deny” policy=read,write,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content="facebook"] disabled=no}
Script untuk disable firewall di hari libur dan enable di hari kerja :
/system script add name=”fb-holiday” policy=write,read,policy,test,sniff source={:if ([/system scheduler get [/system scheduler find on-event="fb-deny"] disabled] = true) do [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=no] else [/system scheduler set [/system scheduler find on-event="fb-deny"] disabled=yes]}
Kelima, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya :
Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :
/system scheduler add name=”fb-08:00″ start-date=jan/01/1970 start-time=08:00:00 interval=1d on-event=”fb-deny”
Schedule untuk mematikan (disable) firewall pada jam istirahat (12:00) :
/system scheduler add name=”fb-12:00″ start-date=jan/01/1970 start-time=12:00:00 interval=1d on-event=”fb-allow”
Schedule untuk mengaktifkan kembali (enable) firewall pada jam kerja (13:00) :
/system scheduler add name=”fb-13:00″ start-date=jan/01/1970 start-time=13:00:00 interval=1d on-event=”fb-deny”
Schedule untuk mematikan (disable) firewall di luar jam kerja ke atas ( > 17:00) :
/system scheduler add name=”fb-17:00″ start-date=jan/01/1970 start-time=17:00:00 interval=1d on-event=”fb-allow”
Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :
/system scheduler add name=”fb-sabtu-minggu” start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event=”fb-holiday”
Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :
/system scheduler add name=”fb-senin” start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event=”fb-holiday”
selamat mencoba
 
Url: http://aminmuzaeni.blogspot.com/2012/09/block-facebook-dilayer7-schedule.html

Share this

Related Posts

Previous
Next Post »

2 komentar

Write komentar
Anonim
2 Februari 2015 15.26 delete

kenapa kalo saya blokir youtube tidak bisa akses playstore dari android

Reply
avatar
26 Oktober 2015 17.27 delete

con ngũ trảo hoả long, mỗi con đều dài bốn năm ngàn mét, mặt trên tràn ngập hỏa diếm mà bọn họ chưa bao giờ nhìn thấy, bọn họ thầm đoán hỏa diễm này ngay cả dị hỏa cũng không thể so sánh được.

- Ao....ao...

Hai con hỏa long ở trên không gào thét, sau đó há mồm phun ra ngọn lửa ngập trời, cả hư không cũng tràn ngập trong biển lửa.
dongtam
mu moi ra hom nay
tim phong tro
http://nhatroso.com/
nhac san cuc manh
tổng đài tư vấn luật
http://dichvu.tuvanphapluattructuyen.com/
văn phòng luật hà nội
tổng đài tư vấn luật
thành lập công ty trọn gói
http://we-cooking.com/
chém gió
trung tâm ngoại ngữ
- Hỏa Long lợi hại, mọi người nhanh chóng cùng công kích.

Lão ma Bàn Thiên sắc mặt thay đổi, lập tức bố trí xong một đường Đấu khí phòng ngự vòng, đồng thời công kích về phía hai con hỏa long.

Lúc này mọi người nhìn thấy lão ma Bàn Thiên bắt đầu công kích, sau đó cùng nhau công kích, bọn họ đều tự bố trí xong Đấu khí phòng ngự vòng, từng đường công kích đánh về phía hai con Hoả long khổng lồ giữa không trung.

Reply
avatar